You are here

Instalimi i VMWare

altiX's picture

Kam problem me instalimin e VMWare ne Etch!
Edhe pse VMWare ka kohë që e përdori; që nga hapat e parë (ver 4.xx) dhe thuaja në të gjitha shpërndarjet e Linuxit e kam instaluar, këtu po më paraqiten probleme.
Së pari po paraqes Versionin që përdor:
cat /proc/versionLinux version 2.6.18-3-686 (Debian 2.6.18-7) (waldi@debian.org) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-20)) #1 SMP Mon Dec 4 16:41:14 UTC 2006
kernel-headers i kam te instaluara
aptitude install kernel-headers-`uname -r`
megjithatë:
..................
Unable to install the .desktop menu entry file. You must add it to your menus byhand.
Trying to find a suitable vmmon module for your running kernel.

None of the pre-built vmmon modules for VMware Workstation is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include]
Versioni që përdor i VMWare është 5.5.1

laurenti's picture

Zakonisht unë instaloj VMware Server në Debian dhe nuk kam ndeshur ndonjëherë ndonjë problem serioz.

Një udhëzues mbi instalimin e VMware server (që me pak ndryshime mund të përdoret për Etch) e gjen tek: HowtoForge.

Përsa i takon rastit tënd, duhet të japësh mesazhet e log të iinstalimit ose të gabimeve gjatë nisjes....

altiX's picture

Përshëndetje Laurent,

E instalova pa problem.Nuk zgjati as 3-4 minuta.
Problemi më parë ishte, unë dëshiroja ta instaloja VMWare Workstation 5.5.1.Ndoshta duhet ndonjë version ma i ri?
Sa për fillim... le të mbetet edhe kjo.
Lexova diku se kishte dalë edhe Versioni 6.0 më duket i VMWare Workstation?

Për t' mirë

laurenti's picture

Quote:

VMware Workstation 6.0 Beta Program

Dear VMware Customer,

We are pleased to invite you to the VMware Workstation 6.0 Beta Program. Workstation 6.0 includes exciting new features, including:

Support for Windows Vista - Use Windows Vista as host operating system

Multiple monitor display - You can configure a VM to span multiple monitors, or multiple VMs to each display on separate monitors.

Integrated Virtual Debugger - Workstation integrates with Visual Studio and Eclipse so you can deploy, run, and debug programs in a VM directly from your preferred IDE.

Automation APIs (VIX API 2.0) - You can write scripts and programs to automate VM testing.

Headless mode - You can run VMs in the background without the Workstation UI You can find detailed information on new features, answers to frequently asked questions, links to download the product, release notes, etc. at:

http://act.vmware.com/servlet/cc5?NuOpQTACWQWVHgKpRSxtpILjhQplV2VW

Your serial keys will be provided to you once you have completed the registration survey. Please save the serial keys for your own record.

In addition, we have created a discussion forum where you can connect with other beta users to discuss product features, post questions, etc. You can find the discussion forum here:

http://act.vmware.com/servlet/cc5?NuOpQTACWQWVHgKpRSxtpILjhQplV2VS

Please note that the discussion forum is not the mechanism to request tech support.

We ask that you give us candid feedback on the software and the documentation. If you encounter problems while testing the release, please submit a Service Request (SR) here.

http://act.vmware.com/servlet/cc5?NuOpQTACWQWVHgKpRSxtpILjhQplV2VY

We ask you to make all problem reports using the web form above as it is the only way that they are reported to the engineering team. Please do not send email reports as they may get misfiled.

Best regards,

The VMware Workstation Team

altiX's picture

E instalova VMware Workstation 5.5.3 ne Etch.
http://img453.imageshack.us/img453/5731/1aou4.png
Problemi është se gjatë hapjes së një Makine Virtuale, VMWare "ngrinë".I njëjti problem ishte edhe te VMWare Server 1.0.1.
Kam instaluar më duket gjërat e nevojshme:
fglrxinfodisplay: :0.0  screen: 0OpenGL vendor string: ATI Technologies Inc.OpenGL renderer string: RADEON 9250/9200 Series DDR GenericOpenGL version string: 1.3.1091 (X4.3.0-8.28.8)
gcc -vUsing built-in specs.Target: i486-linux-gnuConfigured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --with-tune=i686 --enable-checking=release i486-linux-gnuThread model: posixgcc version 4.1.2 20061028 (prerelease) (Debian 4.1.1-19)
fgl_glxgearsUsing GLX_SGIX_pbuffer647 frames in 5.0 seconds = 129.400 FPS752 frames in 5.0 seconds = 150.400 FPS734 frames in 5.0 seconds = 146.800 FPS
glxinfo | grep directdirect rendering: Yes# glxgears -iacknowledgethatthistoolisnotabenchmark5380 frames in 5.0 seconds = 1075.982 FPS5343 frames in 5.0 seconds = 1068.584 FPS
Në Ubuntu dhe Debian Sid funksionon pa problem!
http://img185.imageshack.us/img185/3220/pamjaekranituj7.png
http://img453.imageshack.us/img453/308/pamjaekranit1hu2.png
http://img453.imageshack.us/img453/5111/pamjaekranit3om1.png
...Ne Etch paraqitet kështu nëse e startoj nëpërmjet Terminalit:
/usr/bin/vmware/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)(vmware:3089): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))(vmware:3089): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))(vmware:3089): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))(vmware:3089): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))(vmware:3089): libgnomevfs-WARNING **: Cannot load module `/usr/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6))
Une kam:
gcc version 4.1.2 20061028 (prerelease) (Debian 4.1.1-19)

laurenti's picture

Rruga më e thjeshtë:
sudo cp /usr/lib/libpng12.so.0 /usr/lib/vmware/lib/libpng12.so.0/

Mbishkruaj file ekzistues tek /usr/lib/vmware/lib/libpng12.so.0/

altiX's picture

Quote:
Mbishkruaj file ekzistues tek /usr/lib/vmware/lib/libpng12.so.0/

...I shtova edhe:
ln -sf /usr/bin/gcc-4.1 /usr/bin/gcc
Tash funksionon edhe ne Etch.
http://img375.imageshack.us/img375/9859/6ago2.png

altiX